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Tutorial 1- Getting Started:

¢ First, you will learn how to find maps on your computer

Open “My Computer” -> Goto “C” (the C:// Drive) -> Go to “Documents and Settings”
-> Open the folder of your windows name
& > Open * Application Data’ (see NOTE if you dor't see this folder)
-> Open “My Battle for Middle-earth(tm) |1 Files’
Z Onen*“ Maps

In“Maps’ are al of the Folders of Custom maps you have. When you download a
map, put all of the files that came with it into afolder with the EXACT name of the map.
If you don’t do exactly this, the map won't show up in the game!

Tools Help
Map Network Drive... NOTE: To see hidden files and folders such as
Disconnect Network Drive. .. “Application Data’: go to “Tools’ in any folder at the top -
Synchronize... > Folder Options -> View
Folder Options... 1 -> Select SHOW hidden files and folders.

) Hidden files and foldems
’;} Do mot show hidden files and folders
B (&) Show hidden files and folders

Folder Options

General | View | File Types | Offline Fles

TIP: Before you start WorldBuilder, I recommend
that you press Ctri+Alt+Delete.

This opens the windows task manager. Minimize the task manager, and you still have a
nifty window in your system tray that shows you how much CPU you are using (How
busy the computer is). When it fills up with bright green, that means that your computer
isVERY busy and that you shouldn’t keep working until it cools down from 100%. This
might happen alot when using WorldBuilder. Stay patient and don’t push your computer
too hard or IT WILL CRASH! (That's bad)

=] Windows Task Manager

[Processes: 31 (50 Lisage: 0% ) Commit Charge: 2040 [ 12508 _J
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¢ Next you will learn how to start WorldBuilder, and open and save maps

To start the WorldBuilder program, click

-> Start menu

-> All Programs | s The Battle for Middle-arth(tm) II Worldbuider
-> Electronic Arts
-> The Battle for Middle Earth (tm) |1

-> The Battle for Middle Earth (tm) Il WorldBuilder

Click Accept Terms Wait whileit loads...

ages suFF;.-red' I::;?ou. AtEA's

_é Accept Terms Carl

Y ou should now be looking at a screen like this:
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@ 2008 Electronic Arts Inc. All Rights Reserved.

I Open Map

To open amap, go to File -> Open.

Select the map you want
and click OK.
—Map name:
| Mission|
Saving isvery similar. Go to File -> Save,
and typein aname, and click OK. |
Cancel
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+ Now you will learn how to look around in WorldBuilder.

Looking around is quite easy. Simply hold down the Left Mouse Button and drag.
The map moves too. To rotate the camera, hole down the Mouse Wheel and drag. Now
the map rotates. To zoom in and out, scroll up and down with the Mouse Wheel. Click
the Mouse Wheel to reset the camera. If you want to move all the way across amap, it is
faster to reset to normal zoom and then move. Zooming out and then moving slows down
the computer and takes longer.

Also, in some maps, you will need to view the ground directly from above. Press
Ctrl+F to switch into “Look Down” mode. Doing this uses more system resources, but
you may need it sometimes.

¢ How do I put objects onto the map in WorldBuilder?

B o o o= =B Bl On the tool bar,
-~ MordorCaveTroll_Summoned look for this icon
: MnrdannrsairEanner and click it. This
- MordorCorsairsQfl dmbar opens up the Obj ect

- MordorCorsairsQOfl dmbarHorde

-~ MaordorCorsairsOfUmbarHordeInn library on the side

- MordorDrummerTroll panel- NaVlgate the
- MordarDrummerTroll_Temp folders to find an
- MordorEasterling object to put onto
- MordorEasterlingHorde the map. Objects
- MordorEasterlingHordeCbsolete like buiIdings and

- MordorEasterlingHordePorcupine
- MordorEasterlingPorcupineHorde

units buildable
ingame are found
in the “ByNativeType” folder in the folder with the name of their faction. Once the object
you want has been selected and shown in the sample window, move your mouse to the
map window. The object appears with the cursor and will be placed on the map when you

= Left Click the mouse. Y ou can move/look around like normal while the
object is selected, however, Right Clicking the mouse without moving it
will deselect the object and put you back in norma mode. Y ou can aso
go back into normal mode by clicking this (see |eft) button in the toolbar.

To rotate an object, hold down the left mouse button while placing the object. The object
will rotate in the same way you can rotate a building in the game before building it.

NOTE: Thistroll can be found under:
ByNativeType -> Mordor -> Units -> MordorDrimmerTroll
NOTE: If WorldBuilder asks, put the object on team *PlyrMordor/teamPlyrMordor”.
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¢ How do I change an object once I place it in WorldBuilder?

Object Properties

General ) ogical ] Sound l

Name: |

Team:  [plyrMordar/teamPlyrMordar |
Eventlist: | <Default> -]
InBase: | =

XY Pos:| 1061.75, 1247.37

Z:W j Angle:m j - I_J

[+ Align to terrain f* No Scale
Time: |Llse Map Time j
Weather: |L|SE Map iﬁfeaﬂwej
General §f Logical lSDund]
Initial Health % |1|:||;|=5.1, j |
Max HP:; | Default For Unit j
Aggressiveness: |Nl:|rmal j
Experience Level: |1 ﬂ
Stance: |Llniniﬁalized j
I+ Enabled I+ AL Recruitable
[ Unsellable W Powered
[ Targetable [
[ Indestructible [+ IsSelectable
i Owerride
Distance
stepping: | g Targeting:
Shroud:

—

Available Uparades:

Object properties can also be changed in
world builder. If you select an object on
the map, the window on the side will show
that objects properties and allow you to
change them. The properties are sorted
into 3 sections:

General, Logical, and Sound.

Under the General category, the first
property is the name of the object. The
name of an object isused if you want to
reference this object using scripts. The
team iswhat team will own the object at
the start of the map. XY Position iswhere
the object is on the map (generally used to
refer to using scripts, we'll discusthis
later). Z Position is how high off the
ground an object is. Be careful that you
don’t bury an object (if thisvalueis
negative), because units in the game will
still move to go around an underground
object even if you can't seeit. Angle isthe
direction an object is facing. O=East, and
the object goes toward North as the value
of this gets bigger. Y ou can Scale an object
by selecting the choice above “No Scale’
and dragging the slider to make the object
bigger or smaller, or typing in your own
number.

Initial Health is how much health the
object will have at the start (like 50%, €tc.)
Other changeablesinclude Max HP (an
objects health when not damaged),
Aggressiveness (How aggressive an
object, unit in this case, will be during the
game), Experience Level (What level of
experience an object will start at), and
Stance is the stance the units will start at,
like “aggressive” or “battle” stances.
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In the clickable boxes below the drop down options, you can set if the object is:
Enabled (can move and respond to its environment),

Unsellable (the object can’t be sold, use thisis you don't want a player to sell acertain
building),

Targetable (can be targeted by enemy units),

Indestructible (cannot be destroyed),

Al Recruitable (can be recruited to do things by an allied computer),

Powered (can animate ingame and do things. If something is not powered, it can’t do
anything),

Is A Base (can be built as a custom base. If this box is not checked for a base, once the
base is destroyed, it cannot be rebuilt), and

IsSelectible Override (the object cannot be selected by a pointer. This is recommended
for scenery).

DISTANCE SETTINGS:

Stopping Distance changes the stopping distance is for moving units (Don’t worry about
this).

Targeting Distance is the maximum distance an object can be from something before it
can target it (for example, you could set a catapult to only be able to attack something if it
is 20 feet away).

Shroud Distance is the maximum distance from the object that it can reveal/unshroud
the map.

Y ou can also use the Available Upgrades window to give units any available upgrades

. I
General | Logical {Sound Sound is an additional sound attached to
the object. You don't really use this
Attached Sound: |GimiivoiceDisengage =l much. You can also select if the sound
_ loops, or change volume settings for the
W Customize I+ Enabled [ Looping sound
Priority: |NORMAL -
Yolume: | 115

Min Volume: | 105

Min R.ange: | 160

Max Range: | 540
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¢ How do I change the size of the map WorldBuilder?

Resize &

=10 feet
Vert {y) size: I g0 * 10 feet
Border size: I 10 * 10 feet

Initial height (feet): I 3

Anchor:

Horz (x) size: | 60

[ o |

Cancel

[ Scale: 1.0

[T Scale Sounds | 1.0

To change the size of themap in
WorldBuilder, go to File -> Resize.

The resize window should come up. Enter
the new dimensions of the map that you
want, the border size and what height you
want the terrain to start at. The anchor
selection chooses where you want the
objects from the old map to be placed on
the new map. For example, select the
middle to place old objects at the center of
the new map, or select bottom-middle for
the objects to be centered at the bottom of
the map. (You may need to do some math if
you are shrinking the map. | recommend
taking away 50 ft. at a time from the

dimension you want to shorten. Choose the side-center spots across from the side you
want to shorten. Try this a few times to get the hang of it.) If you check “Scale’, the
objects will be placed on the scale of the previous map. Use this if you want to make a
map bigger, but don’t want to manually move all the objects to their new places. “Scale
sounds’ does the same thing, but for sound objects.

NOTE: Soundswill NOT be scaled if you check “Scale” but not “Scale sounds’.

¢ How do I change the border of the map WorldBuilder?

To change the [I EF o
border of the map,

click the “Border” -
button. This gives you control of
the border tool. Click and drag
the orange border to change it.
The border will stay square, and
you will not be able to move the
border from its spot in the
bottom-left. To make a new
border, click the bottom-left
corner and drag away from the
corner. This new border can be
named and used with scripts to
change the map while playing it.

© This tutorial is copyrighted by worldbuilder.org.
Any replication of this document physically or electronically is prohibited.



TIP: ifa map has a lot of objects, and you have a hard time
because you keep accidentally selecting an object, click this
button in the toolbar. It prevents you from selecting objects, and
this may be helpful.
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TIP: Remember to save often. WorldBuilder may crash a lot, and if it does,
you’ll loose a lot of work if you’ve forgotten to save the map.

To progress to the next tutorial:

v Create anew map named “Tutoria 1" at any dimensions.

v" Resize the map to be only 20x20 feet, and have a border of 10 feet.

v Place 2 drummer trolls (objects) on the map next to each other. Look at the
“NOTE” on the bottom of page 3 if you need help find the troll in the object
library.

v" Name one of thetrolls“Talllaxguyl” and the other one your name or nickname.

v For the troll named “Talllaxguy1”: make that troll float in the air, and be twice as
big as the other troll. Make the troll with your name/nickname start with only
50% health, but make it indestructible.

v" Move the orange border so that one troll isinside the border and onetroll is
outside of it (Y ou may need to switch into “Look Down” mode).

Disclaimer:

"Thistutorial is not endorsed by or affiliated with Electronic Arts, or itslicensors. Trademarks
are the property of their respective owners. Game content and materials copyright Electronic
ArtsiInc. and itslicensors. All Rights Reserved."
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