The 3rd Age

Age of the Firstborn - The Rebirth

Age of the Firstborn - The Rebirth

Continues on Elrond99's Age of the Firstborn mod by turning time back to around TA2000.

Button for The 3rd AgeButton for The Dwarf HoldsButton for The Elven AllianceButton for Helm's Deep Last HopeButton for GothmogtheOrcButton for BFME+Button for The Four AgesButton for HDR HeadquartersButton for Middle Earth CenterButton for Project Perfect Mod

Become an affiliate!

   

Quick Lists

Top Rated Popular New Updated Last Comments Users

Register and log in to move these advertisements down

The Peloponnesian Wars

Avatar of mike_

mike_

Category: Beta Mods
Created: Thursday December 16, 2010 - 13:56
Updated: Sunday January 1, 2012 - 23:13
Views: 16190
Summary: The Peloponnesian Wars (or TPW) aims to bring BFME2 into Greece, 5th Century BCE.

Rating

Staff says

4.4

Members say

4.8

Average

4.6/5.0

15 votes

This mod will replace the regular factions of BFME2 with two completely new and original factions - Athens and Sparta. Historical accuracy, innovative gameplay and a high level of quality are musts for this project.

Links / Downloads

 HitsAdded
Alpha 0.300 Download Link (First public release)1401January 1, 2012 - 23:13
The Peloponnesian Wars Moddb Profile.2143December 16, 2010 - 13:57
The Peloponnesian Wars Forum.1327December 16, 2010 - 13:57

Comments

Display order: Newest first

laslas - Thursday August 9, 2012 - 12:28

Hey guys, i've had that problem too, fix:
Just download and install patch 1.06 and it should work! :D
Now, uhm there seems to be a slight problem, when i go to skirmish mode i can only play with Sparta :( .
And some of the units only die if you hit them for like 11 times with a hero.
Still Great mod!
Greetings , Laslas

TheWitch-King - Friday August 3, 2012 - 22:24

I have the same problem what must we do?Please tell us,i think it is a good mod and i want to play it!

Sauron's eyes and ears - Thursday January 19, 2012 - 20:48

I get an error when I try to play this mod:

Expected floating point value, math op, or predefined macro, but found 'ELNEN_MIRKWOOD_ARCHER_DAMAGE_UPGRADE_PIERCE'
Error parsing field'Damage' in block 'Weapon' in file 'Data\INI\Weapon.ini, line 2245.
Error parsing field' Damage' in block 'Weapon' in file 'Data\INI\Weapon.ini, line 2245.
Error parsing INI block ' Damage' in file 'Data\INI\Weapon.ini'.

Normally I can sort errors out myself, I I have no idea what to do about this one, please help me out so I can play this mod (witch looks awesome by the way!)

Rob38 (Team Chamber Member) - Sunday January 1, 2012 - 23:14

Added download link.

Buffo - Tuesday August 23, 2011 - 5:48

@FellbeastIII
You don't have to wait^^ You can already download an alpha version of the mod. Just check out their moddb profile ;)

Irenë Hawnetyne - Thursday August 18, 2011 - 2:22

Seriously can't wait!!! Looks like the best mod I've EVER seen!

modboy451 - Thursday December 23, 2010 - 11:22

i agree with clank...me and another friend are dying fot this to release...

clank234 - Monday December 20, 2010 - 4:48

This mod looks really good so far. It's also good that you did not make a replika of 300. I'm really looking forward to playing this :)

Go to top

 

"One site to rule them all, one site to find them,
one site to host them all, and on the network bind them."

 
14:12:08